Error:Kotlin: Module was compiled with an incompatible version of Kotlin.

一、问题:运行spring boot项目时,idea报出错误:时提示报错如下图:

错误代码:

Error:Kotlin: Module was compiled with an incompatible version of Kotlin. The binary version of its metadata is 1.6.0, expected version is 1.1.16.

二、产生原因:

这个报错大概意思:模块是用不兼容的Kotlin版本编译的。

原来是idea的kotlin插件版本比pom中的低。

三、解决思路:

  1. 把项目里面的版本降一下

  2. 一种是升级下idea插件的版本

四、解决办法:

升级Kotlin版本有两种方法步骤如下:

4.1、打开kotlin面板


Windows系统:File -> settings -> Languages & Frameworks -> Kotlin

mac系统:Preferences -> Languages & Frameworks -> Kotlin

4.2、点击Check again,然后点击install即可

4.3、等待安装成功即可

4.4、注意:安装完成后一定要重启项目。

参考:Error:(34, 50) Kotlin: Class ‘kotlin.Unit‘ was compiled with an incompatible version of Kotlin. The_class 'kotlin.unit' was compiled with an incompati-CSDN博客

相关推荐

最近更新

  1. TCP协议是安全的吗?

    2024-06-11 19:06:05       8 阅读
  2. 【Python教程】压缩PDF文件大小

    2024-06-11 19:06:05       9 阅读
  3. 通过文章id递归查询所有评论(xml)

    2024-06-11 19:06:05       10 阅读

热门阅读

  1. 使用redis构建简单的社交网站

    2024-06-11 19:06:05       5 阅读
  2. c语言之 **指针

    2024-06-11 19:06:05       6 阅读
  3. 008.googleNet-FashionMNIST-正确率90.510

    2024-06-11 19:06:05       8 阅读
  4. Android13 Settings 左上角箭头图标点击无效

    2024-06-11 19:06:05       5 阅读
  5. 【摘葡萄game】

    2024-06-11 19:06:05       6 阅读
  6. C++ Primer Chapter 8 The IO Library

    2024-06-11 19:06:05       5 阅读
  7. 深度学习的可微渲染

    2024-06-11 19:06:05       6 阅读
  8. Linux学习问题

    2024-06-11 19:06:05       6 阅读
  9. NAT

    NAT

    2024-06-11 19:06:05      6 阅读
  10. 享元模式

    2024-06-11 19:06:05       4 阅读