【python】flask相关包依赖关系问题

【背景】

做flask项目时,由于涉及多个包,比如flask,flask-wtf,werkqeug等,不同版本情况下,互相依赖关系的确实会导致报错。比如报某个依赖无法从flask的相关包中导入等。

【解决办法】

实测可用版本搭配如下:
flask2.3.0
flask_wtf
1.2.0
werkzeug==2.3.0

【安全语句】

pip install flask==2.3.0
pip install flask_wtf==1.2.0
pip install werkzeug==2.3.0

相关推荐

  1. 【python】flask相关依赖关系问题

    2024-06-09 13:32:03       7 阅读
  2. jar 依赖相关

    2024-06-09 13:32:03       37 阅读
  3. Python:Scrapy+Selenium相关依赖记录

    2024-06-09 13:32:03       32 阅读
  4. ubuntu安装deb解决依赖关系错误问题

    2024-06-09 13:32:03       5 阅读
  5. 关于Jupyter的相关问题

    2024-06-09 13:32:03       9 阅读
  6. AndroidStudio开发 相关依赖

    2024-06-09 13:32:03       14 阅读

最近更新

  1. TCP协议是安全的吗?

    2024-06-09 13:32:03       8 阅读
  2. 【Python教程】压缩PDF文件大小

    2024-06-09 13:32:03       9 阅读
  3. 通过文章id递归查询所有评论(xml)

    2024-06-09 13:32:03       10 阅读

热门阅读

  1. HTTP常见响应状态码

    2024-06-09 13:32:03       6 阅读
  2. 深入了解Git:从数据模型到集成IDEA

    2024-06-09 13:32:03       7 阅读
  3. C语言---深入指针(4)

    2024-06-09 13:32:03       6 阅读
  4. 回溯之分割回文串

    2024-06-09 13:32:03       7 阅读
  5. 【环境搭建】2.阿里云ECS服务器 安装MySQL

    2024-06-09 13:32:03       6 阅读
  6. 2 程序的灵魂—算法-2.2 简单算法举例-【例 2.5】

    2024-06-09 13:32:03       7 阅读
  7. 【小海实习日记】金融-现货以及合约理解

    2024-06-09 13:32:03       8 阅读
  8. 【Qt】Item Views与Item Widgets的区别

    2024-06-09 13:32:03       8 阅读
  9. qt自定义事件过滤器

    2024-06-09 13:32:03       6 阅读