spring-data-mongodb版本兼容问题

spring-data-mongodb与mongodb驱动有兼容性问题,不匹配会报NoSuchMethod异常,mongodb的java驱动包在4.0之后由mongodb-java-driver更名为mongodb-driver-sync。

spring-data-mongodb包依赖中有mongodb-driver-core,但缺诸如MongoCollection等类。


官方说明:Spring Data MongoDB - Reference Documentationicon-default.png?t=N7T8https://docs.spring.io/spring-data/mongodb/docs/4.2.0-M2/reference/html/#compatibility.matrix

 官方文档更新的速度有限,比较新的版本没有reference文档,没得参考。

 

 4.1以下的兼容性:

兼容性列表: 

 mongodb驱动与mongodb版本匹配列表如图,驱动和mongodb版本不匹配只是不能使用mongodb的新特性,不影响正常使用

Icon

Explanation

All features are supported.

The Driver version will work with the MongoDB version, but not all new MongoDB features are supported.

No mark

The Driver version is not tested with the MongoDB version.

 案例使用版本:

"spring-data-mongodb" : "org.springframework.data:spring-data-mongodb:3.4.5",
"mongodb-driver-sync" : "org.mongodb:mongodb-driver-sync:4.6.1"

 

相关推荐

  1. new Date(时间)IOS兼容问题

    2024-06-10 10:00:04       10 阅读
  2. Spring Data访问 MongoDB(十六)----CDI集成

    2024-06-10 10:00:04       18 阅读
  3. 解决 Pytorch 和 Cuda 版本兼容问题

    2024-06-10 10:00:04       6 阅读

最近更新

  1. 国际化项目开发中关于时间的问题二

    2024-06-10 10:00:04       0 阅读
  2. Linux知识汇总

    2024-06-10 10:00:04       0 阅读
  3. Flink集群运行模式

    2024-06-10 10:00:04       0 阅读
  4. 617作业

    617作业

    2024-06-10 10:00:04      0 阅读
  5. k8s_DaemonSet和Deployment区别

    2024-06-10 10:00:04       0 阅读
  6. 细说MCU定时器中断的实现方法

    2024-06-10 10:00:04       0 阅读
  7. webpack之HMR

    2024-06-10 10:00:04       0 阅读

热门阅读

  1. 006 CentOS 7.9 elasticsearch7.10.0安装及配置

    2024-06-10 10:00:04       8 阅读
  2. 1341. 电影评分

    2024-06-10 10:00:04       5 阅读
  3. 如何学好量子计算机技术的两种思路

    2024-06-10 10:00:04       5 阅读
  4. 爬山算法详细介绍

    2024-06-10 10:00:04       9 阅读
  5. 4. 流程控制语句

    2024-06-10 10:00:04       7 阅读
  6. vscode 好用的插件

    2024-06-10 10:00:04       7 阅读