文华财经红绿多空趋势量化买卖点指标公式源码

LC:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;

RSIF:=90-RSI1,COLOR33DD33;

A4:=((C-LLV(L,33))/(HHV(H,33)-LLV(L,33)))*67;

ABC22:=LLV(LOW,10);

ABC33:=HHV(HIGH,25);

动力线:=EMA((CLOSE-ABC22)/(ABC33-ABC22)*4,4);

RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

ACB101:-SMA(RSV,3,1);

ACB102:=SMA(ACB101,3,1);

ACB103:=3*ACB101-2*ACB102;

STICKLINE1(动力线>0 AND ISLASTBAR AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),20,80,0,1),COLORYELLOW;

STICKLINE1(动力线>=1.75 AND 动力线<3.2 AND ISLASTBAR AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),50,65,2,0),COLORRED;

STICKLINE1(动力线>=3.2 AND 动力线<3.45 AND ISLASTBAR AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),65,72,2,0),COLORLIGHTRED;

STICKLINE1(ACB103<ACB101 AND ISLASTBAR,30,70,1,1),COLORGREEN;

STICKLINE1(动力线>0 AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),95,94,1,0),COLORFFBBFF;

STICKLINE1(动力线>=0.5 AND 动力线<1.75 AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),95,94,1,0),COLORYELLOW;

STICKLINE1(动力线>=1.75 AND 动力线<3.2 AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),95,94,1,0),COLORRED;

STICKLINE1(动力线>=3.2 AND 动力线<3.45 AND ((ACB103>ACB101 AND ACB103<REF(ACB103,1)) OR ACB103>ACB101),95,92,3,0),COLORRED;

STICKLINE1(ACB103<ACB101,95,94,1,0),COLORGREEN;

ABC1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;

ABC2:=SMA(ABC1,9,1)+100;

ABC3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

ABC4:=SMA(ABC3,3,1);

ABC5:=SMA(ABC4,3,1)+100;

ABC6:=ABC5-ABC2;

趋势:IF(ABC6>45,ABC6-45,0);

STICKLINE1(REF(趋势,1)<趋势,趋势,REF(趋势,1),2,0),COLORMAGENTA;

STICKLINE1(REF(趋势,1)>趋势,趋势,REF(趋势,1),2,0),COLORGREEN;

强弱分界:=50,COLORFFFFCC;

底部:=0,COLORBBFFFF;

安全:=20,COLORFFAA66,LINETHICK1;

预警:=80,COLORFFAA66,LINETHICK1;

顶部:=100,COLORFFFF33;

V1:=LLV(LOW,10);

V2:=HHV(H,25);

价位线:=EMA((C-V1)/(V2-V1)*4,4);

DRAWTEXT(CROSS(3.5,价位线),110-4,'卖'),COLORWHITE;

ABC2Q:=REF(LOW,1);

ABC3Q:=SMA(ABS(LOW-ABC2Q),3,1)/SMA(MAX(LOW-ABC2Q,0),3,1)*100;

ABC4Q:=EMA(IF(CLOSE*1.3,ABC3Q*10,ABC3Q/10),3);

ABC5Q:=LLV(LOW,30);

ABC6Q:=HHV(ABC4Q,30);

ABC7Q:=IF(MA(CLOSE,58),1,0);

ABC8Q:=EMA(IF(LOW<=ABC5Q,(ABC4Q+ABC6Q*2)/2,0),3)/618*ABC7Q;

ABC9Q:=IF(ABC8Q>100,100,ABC8Q);

AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;

AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

AA5:=SMA(AA4,13,8);

走势:=CEILING(SMA(AA5,13,8),0);

AA6:=SMA(AA3,21,8);

STICKLINE1(走势-AA6>85,103,100,15,1),COLORRED,LINETHICK2;

主力线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORBLUE;

超短线:=(((主力线-LLV(主力线,21))/(HHV(主力线,21)-LLV(主力线,21)))*(4))*(25),LINETHICK2,COLORBLUE;

ABC11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

ABC21:=SMA(ABS(LOW-ABC11),13,1)/SMA(MAX(LOW-ABC11,0),10,1);

ABC31:=EMA(ABC21,10);

ABC41:=LLV(LOW,33);

ABC51:=EMA(IF(LOW<=ABC41,ABC31,0),3);

主力进场:IF(ABC51>REF(ABC51,1),ABC51,0),COLORRED,NODRAW;

STICKLINE1(ABC51>REF(ABC51,1),0,ABC51,3,0 ),COLOREE0B55;

STICKLINE1(ABC51>REF(ABC51,1),0,ABC51,2.6,0);

STICKLINE1(ABC51>REF(ABC51,1),0,ABC51,2.1,0),COLOR080099;

STICKLINE1(ABC51>REF(ABC51,1),0,ABC51,1.5,0 );

STICKLINE1(ABC51>REF(ABC51,1),0,ABC51,1.5,0 ),COLORB88BBB;

STICKLINE1(ABC51>REF(ABC51,1),0,ABC51,0.3,0),COLOR8800FF;

洗盘:IF(ABC51<REF(ABC51,1),ABC51,0),COLORGREEN,NODRAW;

STICKLINE1(ABC51<REF(ABC51,1),0,ABC51,3,0),COLORE05500;

STICKLINE1(ABC51<REF(ABC51,1),0,ABC51,2.6,0),COLORB0778B;

STICKLINE1(ABC51<REF(ABC51,1),0,ABC51,2.1,0),COLORE09980;

STICKLINE1(ABC51<REF(ABC51,1),0,ABC51,1.5,0);

STICKLINE1(ABC51<REF(ABC51,1),0,ABC51,0.9,0);

STICKLINE1(ABC51<REF(ABC51,1),0,ABC51,0.3,0),COLORBEFFE8;

ABC12:=3;

ABC28:=(3)*(SMA(((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)- LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE -LLV(LOW,27))/(HHV(HIGH,27)- LLV(LOW,27)))*(100),5,1),3,1));

SS1:=(LOW+HIGH+CLOSE*2)/4;

SS2:= MA(SS1,4);

SS3:=HHV(SS2,10);

SS4:=MA(SS3,3);

SS5:=1.25*SS4-0.25*SS3;

XKKJ:=IF(SS5>SS3,SS3,SS5);

FF1:=LLV(SS2,10);

FF2:=MA(FF1,3);

FF3:=1.25*FF2-0.25*FF1;

//DK10:=IF(FF3<FF1,FF1,FF3):

MA13:=MA(C,13);

//ZDHM:=CROSS(C,DK10)AND CROSS(C,MA13)AND CROSS(C,XKKJ);

//ZHM:=CROSS(C,MA13)AND CROSS(C,XKKJ);

//妖股启动:=IF(ZDHM OR ZHM,50,0),COLORYELLOW,LINETHICK3;

动态底部:=EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3);

RSV11:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;

K:=SMA(RSV11,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

短线:=EMA(J,6),COLORRED;

浮筹:=MA(短线,28)*1,LINETHICK2,COLORGREEN;

空方:=MA(100*(HHV(HIGH,35)-CLOSE)/(HHV(HIGH,35)-LLV(LOW,35)),3),COLORYELLOW;

DRAWTEXT(CROSS(浮筹,空方),趋势*1.026,'大加多'),COLORBLUE;

DRAWICON(CROSS(浮筹,空方),趋势,23);

主力进场1:=BARSLASTCOUNT(REF(趋势,1)<趋势)=1;

DRAWTEXT(主力进场1,趋势-10,'★多'),COLORYELLOW;

DRAWICON(主力进场1,趋势-10,9),COLORBLUE,LINETHICK1;

DRAWTEXT(CROSS(空方,浮筹),趋势*1.026,'大加空'),COLORBLUE;

DRAWICON(CROSS(空方,浮筹),趋势,23);

主力进场2:=BARSLASTCOUNT(REF(趋势,1)>趋势)=1;

DRAWTEXT(主力进场2,趋势-10,'★空'),COLORRED;

DRAWICON(主力进场2,趋势-10,10),COLORBLUE,LINETHICK1;

最近更新

  1. docker php8.1+nginx base 镜像 dockerfile 配置

    2024-07-09 17:40:09       4 阅读
  2. Could not load dynamic library ‘cudart64_100.dll‘

    2024-07-09 17:40:09       5 阅读
  3. 在Django里面运行非项目文件

    2024-07-09 17:40:09       4 阅读
  4. Python语言-面向对象

    2024-07-09 17:40:09       4 阅读

热门阅读

  1. FFmpeg——视频拼接总结

    2024-07-09 17:40:09       9 阅读
  2. php框架详解-symfony框架

    2024-07-09 17:40:09       11 阅读
  3. 红黑树,B+树,B树的结构原理及对比

    2024-07-09 17:40:09       9 阅读
  4. 代码随想录算法训练营:21/60

    2024-07-09 17:40:09       10 阅读
  5. Vue3 对于内嵌Iframe组件进行缓存

    2024-07-09 17:40:09       8 阅读
  6. Kafka 面试题指南

    2024-07-09 17:40:09       10 阅读
  7. vue3 插件

    2024-07-09 17:40:09       9 阅读
  8. 【PyQt5】

    2024-07-09 17:40:09       9 阅读